Python Lists


Submit solution

Points: 10 (partial)
Time limit: 8.0s
Memory limit: 64M

Author:
Problem type
Allowed languages
C, C++, Python

Problem Statement

Consider a list (list = []). You can perform the following commands:

insert i e: Insert integer at position .

print: Print the list.

remove e: Delete the first occurrence of integer .

append e: Insert integer at the end of the list.

sort: Sort the list.

pop: Pop the last element from the list.

reverse: Reverse the list.

Initialize your list and read in the value of followed by lines of commands where each command will be of the types listed above. Iterate through each command in order and perform the corresponding operation on your list.

Input Format The first line contains an integer,n , denoting the number of commands. Each line i of the n subsequent lines contains one of the commands described above.

Constraints The elements added to the list must be integers.

Sample Input 0

12

insert 0 5

insert 1 10

insert 0 6

print

remove 6

append 9

append 1

sort

print

pop

reverse

print

Sample Output 0

[6, 5, 10]

[1, 5, 9, 10]

[9, 5, 1]


Comments


  • 0
    CBSCU4CSE23347  commented on Nov. 25, 2023, 12:37 a.m.

    list=[] q=int(input("Enter the number of input : ")) for i in range(q): a=int(input("Enter the number : ")) b=int(input("Enter the index : ")) list.insert(b,a) print(list) del list[0]

    print(list)

    list.insert(1,9)

    print(list)

    list.insert(0,1) print(list) del list[3]

    print(list)

    list.reverse() print(list)


  • -2
    HARECHARAN_S  commented on Dec. 15, 2022, 12:10 p.m. edited

    .